Jump to content

Search the Community

Showing results for tags 'throttle cable'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Forums
    • General Automotive Chat
    • New Member Introductions!
    • Members Rides
    • Car Photoshoots
    • Motorsports
    • Event Coverage
  • Classifieds
    • Latest Parts from our Sponsors
    • Cars for Sale
    • Bikes for Sale
    • Parts for Sale
    • Stuff for Sale
    • Wanted to Buy
  • Sponsors Forums
    • Sponsor Forums
  • Technical & Support
    • Fabrication & Customisation
    • Car Audio & Electrical
    • Nissan Silvia (nissansilvia.com)
    • Nissan Skyline (skyline-gt.com)
    • Nissan GTR (gtroc.com)
    • Nissan 350z (350tuned.com)
    • Toyota (ttuned.com)
    • Mazda (mazdatuned.com)
    • Subaru (subituned.com.au)
    • Mitsubishi (evotuned.com)
    • Honda (hondatuned.com)
    • Euro (eurotuned.com.au)
    • 4WD Chat
    • Bikes
  • Lifestyle
    • General Off Topic Discussions
    • Sports Forum
    • Holidays & Travelling
    • Fitness Diet Bodybuilding
    • Tech & Gadgets
    • Computer & Video Games
    • Movies, Video & TV
    • Music
    • Girls ONLY chat
    • Jokes & Fun Stuff
    • Art, Graphics & Photography
    • Careers & Jobs
  • State forums
    • Australia - South Australia
    • Australia - Victoria
    • Australia - New South Wales
    • Australia - Queensland
    • Australia - Western Australia
    • Australia - ACT
    • Australia - Tasmania
    • Australia - Northern Territory
  • ADMIN & HELP
    • **WEBSITE HELP FORUM**

Calendars

  • Show All
  • Australia - National
  • Australia - QLD
  • Australia - NSW
  • Australia - VIC
  • Australia - ACT
  • Australia - TAS
  • Australia - SA
  • Australia - WA
  • Australia - NT
  • New Zealand
  • Japan - Asia
  • United States & Canada
  • United Kingdom
  • Europe
  • International

Found 2 results

  1. When I'm driving and take my foot off the accelerator the car doesn't stop revving for half a second or so. Noticed it when I started putting the clutch in to change gears and it would rev up. Has been happening the past month roughly, would happen for 10 minutes or briefly and go away though, not sure if it was related but would (while car was off) fully depress and let go of the accelerator a few times and problem would stop majority of the time. Now has become a consistent thing every time I drive it and I have to let off accel and wait a second before putting the clutch in. This a warped or frayed throttle cable? If that's the case was wondering if the S13/S14 throttle cables are the same as the S15 part. Or is it something else?
  2. Hi, Currently fitting Plazmaman plenum, fuel rail, throttle body, and turbo smart fuel reg and ID1000s... and have a few minor issues. Has anyone had experience fitting a Plazmaman intake manifold. It bolts up to the lower part of he factory runners fine, but there are no provisions for throttle cable. How did you run yours and where did you mount the fixed part of the cable? It come with a remote mount block for the idle control, where is the best place to mount this? I plan to use the factory steel fuel lines, whats the best way to change the ends to JIC to fit up speed flow fittings? Any extra advise on where to place things in the engine bay would be appreciated also, eg fuel reg etc Thanks in advance, Martin
×